特定の月のBioStar2モニタリングでイベントログが表示されません
原因
- MariaDBのスキーマが破損しています。
イシューを確認する方法
1. 該当月のテーブル情報を確認します。
2. Heidi SQLもしくはMySQL workbenchを実行します。
3. 以下のクエリを実行します。(2020年3月ログが確認できない場合)
*月を確認してクエリを更新してください。
4. エラーコード:1033を確認します。
解決方法
1. 念のため、DBをバックアップします。
2. BioStar2 Serverを停止します。
3. MySQL Worbenchを実行します。
4. 「t_lstlog」のデータを検索しすべてのデータを削除します
5. 一時DB名を作成します。
6. .t_lg202003と同じテーブル名を作成します。
*月を確認してクエリを更新してください。1, 34, 35列を確認してください。
6-1. Maria DB Serverを停止します。
7. Maria DBのディレクトリに移動します。(C:\Program Files\BioStar 2(x64)\ta\mariadb-10.1.10-winx64\data\NEW DB NAME\)
8. t_lg202003.frmをコピーしC:\Program Files\BioStar 2(x64)\ta\mariadb-10.1.10-winx64\data\biostar2_ac\に貼り付けます。
8.1 Maria DB Serverを開始します。
9. BioStar2 Serverを開始します。
10. BioStar2 Serverで3月のログを確認します。
11. DBを使用しない場合は、一時DB情報を削除してください