Affected version on BioStar 2

  • v.2.7.12 or higher version


Summary

When trying to connect the specific Site ID registered in Airfob portal in "Mobile Access of BioStar 2", you may meet the Error message "Unknown due to Exception error. (2007)"



Solution

Please follow the below procedures.


Login Airfob Portal -> Select the [Site ID] -> Click [Settings] -> Click [Site] ->Go to [Site Security] -> Inactive "Email authentication" as follows.


Note that

--> Suprema does not have any plan to support the "additional authentication" of Airfob-Portal yet in BioStar 2. 

--> To distinguish each issue related to "Mobile Access", Suprema has a plan to introduce the below new warning pop-up instead of the current pop-up "Unknown due to Exception error. (2007)" from v.2.9.4 of BioStar 2.


* New pop-up to be applied from v.2.9.4

BioStar 2 is unable to connect your Airfob Portal account. Please check your Airfob Portal account to see if any of the following cases apply and try again:

- Your Airfob Portal account is dormant due to long-term inactivity.

- Email authentication is enabled in your Airfob Portal account. (2300)


Cause

BioStar 2 does not support the 'additional authentication' supported by Airfob Portal for now



Precaution

Suppose you don't set it to allow the firewall in your network to access Airfob Portal. In that case, you may still not have access to Airfob Portal, although you are inactivating the Email Authentication. If so, please check the firewall status on whether it allows you to access Airfob Portal. 

However, if you can't still access Airfob Portal although checking the status of firewall, please contact Suprema's Technical Support Sector via our support portal. (https://support.supremainc.com/)