対象製品: BioStar 2
バージョン: V2.9.4 and V2.9.5
修正: V2.9.6 (予定)
概要
バックアップしたデータベースをBioStar 2バックアップツールからリストアしようとすると、BioStar 2リストアツールが失敗を返します。
- c: ポイント:この問題は、お客様がBioStar 2をV2.9.3からV2.9.4またはV2.9.5にアップグレードしたサイトで発生します。
ユーザーシナリオ
- BioStar 2をV2.9.3からV2.9.4またはV2.9.5にアップグレードする。
- BioStar 2バックアップツールでサーバーのバックアップを実行する。
- 新しいBioStar 2をインストールする
(お客様がデータベースをバックアップしたバージョンによって、V2.9.4またはV2.9.5になります)。 - BioStar 2リストアツールでデータベースとファイルのリストアを試みる。
- 上の画像のように故障が発生する。
原因
BioStar 2バックアップツールでバックアップした.zipファイルの "manifest.json "ファイルのBioStar 2バージョンがV2.9.3のままです。そのため、BioStar 2 Restoreツールは、バックアップされた.zipファイルが不正なBioStar 2バージョンのものであることを検出します。
一時対策
1. 以下のガイドに従って、BioStar2パッチを適用し、RESTOREツールを再度実行します。
- BioStar SettingでBioStar2のサービスを停止する。
- 右のパッチをダウンロードする。→ FISS-3821.zip
- パッチを解凍し、<C:\Program Files\BioStar 2(x64)>に置く。
- BioStar SettingでBioStar 2のサービスを再起動する。
- RESTOREツールをもう一度実行する。
2. 以下のSupremaのガイドに従って、バックアップしたデータベースとファイルを手動でリストアします。
- Maria DB: [BioStar 2] Database Backup and Restore Instructions (Maria DB)
- MSSQL: [BioStar 2] MSSQL Database Backup and Restore Instructions
3. 管理者権限のあるテキストエディタで「manifest.json」ファイルを修正します。
- BioStar 2バックアップツールからバックアップした.zipファイルの「manifest.json」ファイルを、管理者権限のあるテキストエディタ(メモ帳など)で開きます。
- 「biostar_version」の部分を探して、データベースがバックアップされた正しいバージョンに編集する。
- 「manifest.json」ファイルを保存します。
- BioStar 2 Restoreツールを再実行してください。