Versiones Afectadas: BioStar 2 Ver 2.8.16 & Ver 2.9.0

Versión Fija: BioStar 2 versión 2.9.1 será lanzada en el año 2023 Q1


Resumen 

Cuando realiza la sincronización en BioStar 2 → Configuración → Directorio Activo → Sincronizar → Sincronizar Ahora

La sincronización en el Directorio Activo afecta el ID de inicio de sesión del usuario cuando la opción [Usar para inicio de sesión de BioStar 2] esta inactiva en BioStar 2 → Configuración → Directorio Activo → Servidor de Directorio Activo.

 

Causa

Suponga que la información de usuario como ID de inicio de sesión y contraseña no son idénticos a los datos del Directorio Activo. En este caso, la información del usuario se sobreescribe automáticamente basado en los datos guardados en el Directorio Activo.


Descripción Relevante del Problema 

  1. BioStar 2 → Configuración → Directorio Activo → Aplicar configuraciones 
    Nota Importante : Usar para inicio de sesión de BioStar 2 configurada en inactiva
  2. BioStar 2 → Configuración → Directorio Activo → Sincronizar → Sincronizar Ahora 
  3. BioStar 2 → Usuario → Seleccione uno de los usuarios sincronizados
  4. BioStar 2 → Usuario → Seleccione uno de los usuarios sincronizados → Editar Información de Usuario → Aplicar
    • Correo Electrónico
    • ID de inicio de sesión y contraseña
  5. BioStar 2 → Configuración → Directorio Activo → Sincronizar → Sincronizar Ahora
  6. BioStar 2 → Usuario → Seleccione el usuario editado en el # 4
    • Edite el ID de inicio de sesión y Contraseña que se sobreescribieron con los datos basados en el Directorio Activo

Solución Alterna

Si ya configuró el ID de inicio de sesión de cada usuario y planea no usar el inicio de sesión de BioStar 2 y ahora con el Problema Conocido tiene que editar manualmente la información de cada usuario, siga las pautas a continuación:


Paso 1. Detenga los servicios de BioStar 2

Paso 2. Vaya a C:\Program Files\BioStar 2(x64)
Paso 3. Realice una copia de seguridad del archivo biostar2-webapp.jar ubicado en C:\Program Files\BioStar 2(x64) 
Paso 4. Descomprima el archivo parche y copielo en C:\Program Files\BioStar 2(x64) 

BioStar Ver 2.8.16_AD Synchronization loginID_bug_fixed_patch

Paso 5. Inice servicios de BioStar 2 


Por favor contactese con el equipo de soporte técnico, para recibir el archivo de parche para reparar el bug de ID de inicio de sesión sincronizción con Directorio Activo para otra versión de BioStar 2
Make a request by creating a new ticket in Tech Support Portal